Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1   Report Post  
Old March 1st 18, 10:16 PM posted to rec.radio.amateur.boatanchors
external usenet poster
 
First recorded activity by RadioBanter: Mar 2018
Posts: 2
Default Heathkit SB-200 Help

I have a SB-200, 75 watts in to the amp, the grid voltage, on dead key pegs the meter and the power slowly drops from 500 Watts to about 250 watts and the grid ma drops to about 200ma Grid, ma and watts both drop within 7 seconds.

The swr remains the same, I even changed the Balun thinking the toroid might be saturating until I saw the grid ma.

I have an extra pair of 572B tubes and tried them, same problem so I purchased and installed new 572B tubes, same problem.

So when I tune the amp for max power the grid ma is way out of specs.
Can anybody help with any suggestions? I checked the grid capacitors, their fine. I have no idea what to check next.

Thank you
Eddie kj4fgi

  #2   Report Post  
Old March 2nd 18, 07:48 PM posted to rec.radio.amateur.boatanchors
external usenet poster
 
First recorded activity by RadioBanter: Jul 2006
Posts: 749
Default Heathkit SB-200 Help

In article ,
Edward Vignati wrote:
I have a SB-200, 75 watts in to the amp, the grid voltage, on dead key pegs the meter and the power slowly drops from 500 Watts to about 250 watts and the grid ma drops to about 200ma Grid, ma and watts both drop within 7 seconds.


But the meter light doesn't dim? If you set the meter to HV, is it also
dropping or does it stay nice and steady?

Are there any signs of weird oscillations? Does a scope with a probe
coupled near the output show a decent sine or an increasingly smeary mess?

The swr remains the same, I even changed the Balun thinking the toroid might be saturating until I saw the grid ma.

I have an extra pair of 572B tubes and tried them, same problem so I purchased and installed new 572B tubes, same problem.


So when I tune the amp for max power the grid ma is way out of specs.
Can anybody help with any suggestions? I checked the grid capacitors, their fine. I have no idea what to check next.


The tube is just a big capacitor from the standpoint of the grid drive
circuit. So if the grid is drawing a lot of current, either the grid bias
is in some wacky place (where it's no longer acting as a simple capacitor)
or else there is high frequency trash going into or coming out of it
since the capacitor has a low impedance at high frequencies). Which would
indicate oscillation.

Make sure, of course, that the transmitter driving it is putting out a nice
waveform to begin with. Check those little grid bypass caps. If the 33 ohm
resistors on the grid have been replaced, make sure they are still wirewound
ones and they are physically very close to the tube.

Check for a damaged bandswitch; that is a very very common failure on these
with a lot of weird symptoms.
--scott
--
"C'est un Nagra. C'est suisse, et tres, tres precis."
  #3   Report Post  
Old March 2nd 18, 10:04 PM posted to rec.radio.amateur.boatanchors
external usenet poster
 
First recorded activity by RadioBanter: Mar 2018
Posts: 2
Default Heathkit SB-200 Help

On Friday, March 2, 2018 at 2:48:36 PM UTC-5, Scott Dorsey wrote:
In article ,
Edward Vignati wrote:
I have a SB-200, 75 watts in to the amp, the grid voltage, on dead key pegs the meter and the power slowly drops from 500 Watts to about 250 watts and the grid ma drops to about 200ma Grid, ma and watts both drop within 7 seconds.


But the meter light doesn't dim? If you set the meter to HV, is it also
dropping or does it stay nice and steady?

Are there any signs of weird oscillations? Does a scope with a probe
coupled near the output show a decent sine or an increasingly smeary mess?

The swr remains the same, I even changed the Balun thinking the toroid might be saturating until I saw the grid ma.

I have an extra pair of 572B tubes and tried them, same problem so I purchased and installed new 572B tubes, same problem.


So when I tune the amp for max power the grid ma is way out of specs.
Can anybody help with any suggestions? I checked the grid capacitors, their fine. I have no idea what to check next.


The tube is just a big capacitor from the standpoint of the grid drive
circuit. So if the grid is drawing a lot of current, either the grid bias
is in some wacky place (where it's no longer acting as a simple capacitor)
or else there is high frequency trash going into or coming out of it
since the capacitor has a low impedance at high frequencies). Which would
indicate oscillation.

Make sure, of course, that the transmitter driving it is putting out a nice
waveform to begin with. Check those little grid bypass caps. If the 33 ohm
resistors on the grid have been replaced, make sure they are still wirewound
ones and they are physically very close to the tube.

Check for a damaged bandswitch; that is a very very common failure on these
with a lot of weird symptoms.
--scott
--
"C'est un Nagra. C'est suisse, et tres, tres precis."


Scott thank you , the transmitter is an Elecraft KX3 into a KXPA100, I'm not good with a scope, even though I have one, I will check the resistors, the band switch and grid bypass caps, Thank you very mych

Eddie kj4fgi
  #4   Report Post  
Old March 3rd 18, 05:01 PM posted to rec.radio.amateur.boatanchors
external usenet poster
 
First recorded activity by RadioBanter: Jul 2006
Posts: 749
Default Heathkit SB-200 Help

Edward Vignati wrote:

Scott thank you , the transmitter is an Elecraft KX3 into a KXPA100, I'm not good with a scope, even though I have one, I will check the resistors, the band switch and grid bypass caps, Thank you very mych


Yeah, but watch the B+ when you key down also. If one or more diodes is
partially failed, you can get into a situation where the supply can deliver
a lot of current from the bypass electrolytic quickly, but after a few seconds
it sags because the electrolytic can't charge up as quickly as it discharges.

Big broadcast transmitters often have neon lamps across all of the diodes
in the series string so that when one goes open or high resistance the lamp
lights up.

If the power drops but the B+ holds more or less steady you can ignore this.
--scott

--
"C'est un Nagra. C'est suisse, et tres, tres precis."


Reply
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
FA: TonightHeathkit PK-1 Probe, Collins Panel Meter, Heathkit SB-401 Xtal Option rich Equipment 14 June 12th 06 04:15 PM
FA: TonightHeathkit PK-1 Probe, Collins Panel Meter, Heathkit SB-401 Xtal Option rich CB 13 June 12th 06 04:15 PM
FA: Great StuffHeathkit Tube Set, Heathkit Knobs & Cabinet [email protected] Boatanchors 0 May 27th 06 02:51 PM
FA: Great StuffHeathkit Tube Set, Heathkit Knobs & Cabinet [email protected] Equipment 0 May 27th 06 02:51 PM
FS: Heathkit SB-604 External Speaker and Heathkit Curve Tracer Dave Hollander Equipment 0 June 1st 04 04:28 PM


All times are GMT +1. The time now is 06:09 PM.

Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2004-2018 RadioBanter.
The comments are property of their posters.
 

About Us

"It's about Radio"

 

Copyright © 2017